VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Secure Shell (https://forums.vandyke.com/forumdisplay.php?f=15)
-   -   Copy-n-Paste issues with 6.0.0 build 101 (https://forums.vandyke.com/showthread.php?t=2505)

mdella 10-07-2007 02:02 AM

Copy-n-Paste issues with 6.0.0 build 101
 
Ok, I used to remember a forum for testing the new software but for the life of me this was the only one SecureCRT related so I guess I need to post here...

So I've been trying to do the copy and paste function that I used to activate with a right mouse click on highlighted text. At this point, this version of the software insted does the "paste" function with a right click rather than the original menu pulldown for selection. Is this a bug? Feature? Configuration option that I couldn't find? Or....

Marcos

Chris 10-07-2007 02:16 PM

Marcos,

If you open the Global Options dialog and go to the Terminal page, there is a
setting that will allow you to either paste on the middle or right mouse button.

If you change this to paste on middle button, does this get you back to the
old behavior?

Thanks,
Chris

mdella 10-08-2007 12:55 PM

Changing the mouse keys...
 
Looks like that was the thing that fix the issue, or at least got it back to what it used to be like. Interesting. I did a default install of v5.5 and v6.0beta and the default action on this is definately different. Not sure if that was intentional or not...

Seems pretty substantial to change as a default

Marcos

es01 02-21-2008 12:19 PM

Paste on middle button severely degraded in 6
 
My experience is that in 6.0 (6.0.0 build 183) is that paste on middle button is severely degraded.

In past versions of SecureCRT, the paste on middle button has been rock solid, allowing me to paste when clicking the right and left mouse buttons simultaneously.

In 6, this has changed. Pressing both buttons now bring up the context menu most of the time, as if I only pressed the right button. Occasionally I can get text pasted but more often nothing happens. I have found that I have better luck when pressing the left button slightly before the right, to avoid the menu from popping up, but even then text isn't always pasted.

Is this a known bug, or a new "feature"? Could we have a fix to make it work like before, please?

Thanks,
-Erik

tnygren 02-21-2008 02:00 PM

Hi Es01,

This is an issue that we are aware of and that there is a resolution for in SecureCRT 6.0.1.

SecureCRT 6.0.1 was just released today.

Could you upgrade to this release and let me know if the middle button pasting issue is resolved for you also?

es01 02-21-2008 05:01 PM

One word: Fantastic!
 
I just got the email notification that the update was available, and downloaded & installed
This bug is squashed, thank you very much!

(and what timing, I might add. Less than 2 hours from my first post :D )
-Erik


All times are GMT -6. The time now is 06:57 AM.