VanDyke Software Forums

VanDyke Software Forums (
-   SecureCRT on the Mac (
-   -   CTRL shortcuts not working (

dimension6 12-17-2012 11:30 AM

CTRL shortcuts not working

I am running SecureCRT 7.0.2 on a fully updated Mac (OS 10.8.2), and am having some trouble getting any Control key shortcuts working (I use these heavily when configuring our Cisco equipment). They seem to function as application shortcuts rather than terminal client shortcuts. For example, CTRL+A should move to the start of the line, but instead selects all text. CTRL+K opens up Quick Connect rather than clear all text from the cursor onward.

Is there some either global or OS setting that can solve this?


miked 12-17-2012 11:51 AM


Can you double check that you're pressing Ctrl, not the Command key?
Command-A selects all in SecureCRT for OS X.

Command-K opens Quick Connect in SecureCRT for OS X.
Can you describe the keyboard (i.e.: is it an external keyboard, perhaps PC keyboard, plugged into a Macbook Pro, or something like that)?

dimension6 12-17-2012 12:05 PM

My keyboard is a relatively new Apple USB keyboard with numpad, and I am indeed pressing the control key rather than the command key (they seem to perform the same function).

miked 12-17-2012 01:17 PM

They shouldn't perform the same function. If you open another application, such as Safari, or Terminal, can you press Cmd-A and Ctrl-A, and see if both actions select all for you?

Did you copy sessions from SecureCRT on Windows, or is this a new installation and new session?

dimension6 12-17-2012 01:43 PM

I don't have this issue in other applications (for example, all CTRL functions work properly in Terminal). I did copy the sessions over from a Windows machine, but have also tested by creating a completely new configuration folder.

miked 12-17-2012 02:16 PM

If you use Quick Connect you see the same problem, right?

If so, could you send your SecureCRT Default.ini file and Global.ini file to, with subject Forum Thread 10799 Attn Mike?

dimension6 12-17-2012 04:01 PM

The requested files have been sent. I also have the issue when using Quick Connect.


miked 12-17-2012 06:51 PM

Thank you - we received the files. I will run some tests and let you know...

miked 12-18-2012 05:04 PM

Following further investigation with dimension6 via e-mail, the problem with the Control key behaving like the Command key appears to be related to which Input Source is selected in Mac System Preferences / Language & Text.

If Kotoeri / Romaji is selected, the problem appears. So far Romaji is the only language I've seen that has this effect (so a different Input Source language such as Kotoeri / Hiragana appears to be a workaround).

We have asked our developers to investigate and will post a follow up message to this thread if there's a fix or further explanation.

If anyone else experiences a problem with the Control key behaving like Command, please let us know and refer to forum thread 10799.

miked 01-23-2013 03:11 PM

Problem solved
For those following this forum thread, we have received confirmation from customers that this problem is resolved in version 7.1 and newer.

SecureCRT 7.1 is currently available as a pre-release by request. If you experience the problem with the Control key behaving like the Command key in SecureCRT on Mac OS X, and would like to try 7.1, please let us know.

ACX 04-05-2013 08:36 PM

Hi, I'm using 7.1 beta 3 on Mac but CTRL-W (to clip previos word in bash shell) does not work while other CTRL shortcuts (like CTRL-A, CTRL-E, etc.) work as expected. I'm trying 7.1 beta because I have read this post and I had the same problem with CTRL-W in 7.0.3.
How can I fix it?

miked 04-08-2013 10:53 AM


Have you changed the Input Source setting on your Mac, in System Preferences / Language & Text?

Are you experiencing problems with any other Control-key combinations?

If not, and if all other Control-key combinations are working, I believe your problem is unrelated to the one described in this thread and we should continue working on the issue in the other forum thread where you posted about the issue.

Dennett 05-07-2013 06:20 PM

Ctrl-shortcuts still not working

I'm using SecureCRT V 7.1.0(build 244) on OS X 10.8.3 with PL2303 USB to Serial adapter.

As per other users, I need this for configuration of routers, switches etc, but none of the Ctrl shortcuts work.

I have read and tried all the previous suggestions on this forum but still no joy.

This connection and all Ctrl shortcuts work just fine in every other terminal application I have tried. iTerm, terminal, ZOC, iTerm 2.

This behaviour is only evident in SecureCRT.

This is very frustrating as SecureCRT is my preferred app.

Please help.


miked 05-08-2013 10:17 AM


Can you provide more information about some of the specific Ctrl shortcuts you have tried in SecureCRT and what the expected results were?

Dennett 05-09-2013 12:22 AM

Ctrl key sequences
Ctrl-Y is the key seq required to start the configuration of a new Nortel switch from the console (for example)

Nothing happens at all when I press Ctrl-Y, cannot go any further into switch config to try other sequences.

Ctrl-N and Ctrl-P move one page Next and Previous

Ctrl-R return to previous menu

If I change terminal app (iTerm for example) and hit Ctrl-Y, it takes me to the Nortel menu

I close the iTerm and re open SecureCRT, now the other Ctrl seq's above fail. Nothing at all seems to be sent to the console as there is zero response.

All these work fine from the same Mac with the same hardware from other terminal apps. Just fail in SecureCRT.



Originally Posted by miked (Post 39051)

Can you provide more information about some of the specific Ctrl shortcuts you have tried in SecureCRT and what the expected results were?

All times are GMT -6. The time now is 04:15 AM.