VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Secure Shell (https://forums.vandyke.com/forumdisplay.php?f=15)
-   -   Common Host key Database Issue/help (https://forums.vandyke.com/showthread.php?t=1229)

kalba 01-24-2006 06:40 PM

Common Host key Database Issue/help
 
Hi,

My Unix SSH server changed its host key due to new installation of OpenSSH.

Now when I connect via SecureCRT (5.0.4 Build1065) I receive the following message:

----
The host you specified (hostname.domainname), port 22 matched at least
one entry in the common host key database, but the server's host key did not match any of the entries.

You may need to check with your administrator to
update your common host key database.

It is recommended you verify your host key before continuing.

Server's host key fingerprint (MD5 hash):

--

How do I update my "common host key database" ??.

I have already removed the host key entry from within SecureCRT via the Global config menu option.

Thanks

Tony

tnygren 01-25-2006 04:05 PM

Hi Kalba,

There is a text file that contains links to the host keys that have been accepted in SecureCRT.

It could be that this text file is read only.

The file is called 'hostsmap.txt' and is located in the 'Known Hosts' folder.

This folder is located in the following folder:

C:\Documents and Settings\%user%\Application Data\VanDyke\Known Hosts

Is the 'hostsmap.txt' file or 'Known Hosts' folder set to read only?

kalba 01-29-2006 08:50 PM

Hi,

Thanks for your help so far.

Still not working.

The directories and files you mentioned below are NOT read only.

I also tried renaming the KnownHost folder to see if that effected the issue
and it did not.

Maybe I need to re-install, what do you think ?

tnygren 01-30-2006 12:35 PM

Hi Kalba,

Since the error did not change, it appears that this is not the common host key file that is being used.

This message usually occurs when a common hostkey database is being shared by several users and the users are restricted to only read the database.

The actual location of the hostkey database should be stored in the 'SSH2.ini' file located in the configuration folder.

The location of the configuration folder is listed in the 'Configuration folder' data field in the 'General' category of the 'Global Options' or if a special shortcut is being used, the location will be listed after the '/F' command line switch in the 'Target' data box in the 'Properties' of the shortcut.

To resolve this error, the administrator or another user that has permissions to save to this common location will need to go and update the host key database.

Does this information help?

kalba 02-08-2006 06:34 PM

Hi,

Yes this did help.

It was a permission problem in the Application Data Folder

Thanks

Tony
:D

tnygren 02-09-2006 09:02 AM

Hi Kalba,

I'm glad to hear that the issue with the host key database was resolved! :)

Please let us know if you have any other questions or concerns on our products.


All times are GMT -6. The time now is 06:53 AM.