VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   File Transfer (https://forums.vandyke.com/forumdisplay.php?f=18)
-   -   VShell resume/reput fail - locked file (https://forums.vandyke.com/showthread.php?t=14503)

zybex 04-19-2021 03:08 AM

VShell resume/reput fail - locked file
 
Hi,
I'm using VShell v3.9 SFTP server. When trying to resume a transfer with Reput command after a connection drop, the server replies with:
'The process cannot access the file because it is being used by another process. '

The file remains locked for a long time, even disconnecting/reconnecting doesn't help. Eventually it unlocks and the resume works.

Is there a way to adjust the lock timeout on the server settings?

This only happens when there is a client connection loss (like wifi signal loss or sudden internet connection failure), so the TCP connection probably remains up for some time on the server side.

Thanks!

cboyack 04-19-2021 10:48 AM

Hi zybex,

First off, does your VShell version 3.9 have Enable keep alives enabled under the SSH2 category in VShell's Control Panel?

This option can help the server know more quickly if the peer connection has gone down (but if there's a network component that isn't passing along that notification, as may be the case for you, then having this option enabled might not make a difference).

Quote:

Originally Posted by zybex (Post 54917)
Is there a way to adjust the lock timeout on the server settings?


Under the Common category in VShell's Control Panel, there's an option called Disconnect idle sessions after X minutes, right at the very top.

This option only has the granularity of 1 minute intervals in VShell version 3.9, so the minimum idle time that VShell can enforce in your particular situation is 1 minute.

Alternatively, if you desire to cut the idle timeout even shorter than a minute, VShell version 4.6 allows idle timeouts to be specified in seconds, rather than minutes (this option has been relocated to the SSH2 category in VShell 4.6, FYI).

zybex 04-24-2021 06:13 AM

Thanks Cameron, adjusting the timeout will probably work. Looks like it's currently set to 15 minutes which is way overkill.

I'll check if I can convince out IT dept. to upgrade to v4.6 to further adjust it to our needs.

zybex 04-27-2021 05:11 AM

Cameron,
Can you please let me know the linux config filename and the option name to set there?

cboyack 04-27-2021 09:19 AM

Quote:

Originally Posted by zybex (Post 54943)
Can you please let me know the linux config filename and the option name to set there?

The linux config filename is vshelld_config, and by default, is located within:
/usr/local/etc
The option name depends on the type of connection to VShell.

For SSH2 connections, the option is called SSH2IdleTimeout, and if desired to have the timeout set for 2 minutes, one could uncomment that line and edit it like so:
SSH2IdleTimeout 0

to

SSH2IdleTimeout 2m
FTPS or HTTPS connections (if needed) have similar option names called FTPSIdleTimeout and HTTPSIdleTimeout

Please also note that vshelld requires a reload (vshelld -reload) for any configuration changes to be implemented.


All times are GMT -6. The time now is 02:00 PM.