VanDyke Software Forums

VanDyke Software Forums (
-   General (
-   -   Change physical keyboard (language) settings for sessions (

danieldmb 10-02-2018 02:19 AM

Change physical keyboard (language) settings for sessions
Hi all,

By default when I open SecureCRT, my local keyboard settings (i.e. language) is loaded. I can see this when I go to tools -> Keymap editor.

This is nice when I connect to my linux sessions: SecureCRT seems to adapt my local physical keyboard layout to the one configured at the remote server. So in practice, although the server has a different layout configured (ex. "US"), in my session everything works as if the layout of the remote server is the same as the one in my laptop (ex. "SP").

However, I wanted now to respect the remote server keyboard settings in my session. Is there a way to tell SecureCRT to "follow" the settings found at the remote server?

Hope someone can give me a hand! All the searches I've done so far deal with mapping key strokes to special functions and I believe that what I am looking for is way simpler.

Thanks and regards,

ekoranyi 10-02-2018 09:39 AM

Hi danieldmb,

I'm not sure that I fully understand the problem you're trying to solve. What trouble are you having? What behavior would you like to see from SecureCRT? Can you elaborate on the "US" and "SP" layout? Where are you getting the layout information?

The SSH protocol does not have any method to exchange keyboard information. This means that SecureCRT does not have any information about the remote systems keyboard setup. In fact, SecureCRT is often connected to devices, such as switches and routers, that do no have a keyboard.

danieldmb 10-02-2018 02:43 PM

Hi ekoranyi,

Thanks for your reply! In reality, it is a very simple thing.

I have SecureCRT installed in a laptop running Windows 7 with a Spanish keyboard layout (SP). When I open a new SSH session to a remote Ubuntu Linux server, I can type in as if the same spanish keyboard layout were configured at the remote server. This happens even if the keyboard layout set at the remote server is not spanish, but english (us):


$ cat /etc/default/keyboard

# Consult the keyboard(5) manual page.


$ echo $LANG

I was trying to learn how to disble this behavior for my SSH session so that the remote server could assume that my laptop keyboard is an english (US) layout - as configured at the OS level.

This way, I could for example type in the tilde character "~" by pressing "shift" + "key to the left to nr 1" in my physical spanish keyboard (instead of doing "alt gr" + "4").

Hope it makes more sense now!

ekoranyi 10-02-2018 03:00 PM

Hello danieldmb,

SecureCRT does not have any way to know what the keyboard configuration on the remote server is. It will always use the local keyboard configuration.

That being said, you may be able to get the behavior you're looking for by using mapped keys. Using the example you provided of "~":
  1. While connected to the session in question choose Options > Session Options
  2. Select the Mapped Keys category
  3. Press the Map a Key... button
  4. When prompted, press the Shift-"~" combination
  5. With the Send String function selected enter a "~" in the send string box
  6. Press OK twice to save your changes

You should now be able to press Shift-"~" and have the appropriate character appear. Does this help get you the functionality you're looking for?

All times are GMT -6. The time now is 04:55 AM.