VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   SecureCRT freezes when copying 1000+ lines (https://forums.vandyke.com/showthread.php?t=13116)

markweiser 05-21-2018 07:26 AM

SecureCRT freezes when copying 1000+ lines
 
Hello,

I've noticed every time I have to copy 1000+ lines from SecureCRT to paste somewhere else, SecureCRT simply freezes for a while (around 10+ seconds).

I'm wondering, I understand that there's a large quantity of data that is been copied, but why does it freeze for so much time?
I mean, we all have at least i5 quad core 8gb RAM laptops, and it's copying only text, is it supposed to happen? :confused:

Currently running it in Windows 7 Enterprise, SecureCRT 8.3.2

Appreciate your time,
Marcus

bgagnon 05-21-2018 09:22 AM

Hi Marcus,

I am not sure I understand the exact time of the delay.

Is it while *selecting* 1000+ lines?

Or when you actually choose "Copy"?

If the latter, how do you see the freeze manifest itself? (ie: does SecureCRT title bar display 'Not Responding'?)

In any case, can you provide explicit steps to replicate?

Also, if you have Copy to clipboard as RTF and plain text enabled in the Terminal / Emulation / Advanced category of Session Options, is the issue resolved if you disable it?

markweiser 05-21-2018 06:21 PM

Quote:

Originally Posted by bgagnon (Post 49595)
Hi Marcus,

I am not sure I understand the exact time of the delay.

Is it while *selecting* 1000+ lines?

Or when you actually choose "Copy"?

If the latter, how do you see the freeze manifest itself? (ie: does SecureCRT title bar display 'Not Responding'?)

In any case, can you provide explicit steps to replicate?

Also, if you have Copy to clipboard as RTF and plain text enabled in the Terminal / Emulation / Advanced category of Session Options, is the issue resolved if you disable it?



Well, basically it's reproducible from my side if I copy 500+ lines to the clipboard (selecting and copying).. and yes, SecureCRT becames unresponsive for quite a while (No Responding status)

But after that tip, disabling Copy to clipboard as RTF and plain text the issue no longer happens, even if I copy more than 25000 lines

Thanks a lot!

Marcus

bgagnon 05-22-2018 08:10 AM

Hi Marcus,

Great! I am glad to hear the issue was resolved by changing the configuration.

If you need to make this change to many or all sessions, see this tip on our website.


All times are GMT -6. The time now is 03:08 AM.