VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Vshelld - Setting umask parameter (https://forums.vandyke.com/showthread.php?t=12636)

Mario Izaguirre 03-15-2017 09:55 AM

Vshelld - Setting umask parameter
 
Hi.

I have a problem with these.

In the vshelld_config we're used defaultumask=007 and I have seen that when uploading files with RW-RW- (660) source permissions, when they finish uploading the files they have the same permissions as the source. (660)

I do a test upload a file with 700 permissions and the file is in the destination with the same permissions. (700).

My confusion is, any test that I do with the permissions of files at source always gives me the same result.

┐Should not the mask that has been put on vshell_config be applied?

Note: I have tried using the UMASK in ~ / .vshellrc and the same thing always works.

Any Idea Please.

jdev 03-15-2017 10:44 AM

The DefaultUmask setting is only a default.

An SFTP client will usually change the permissions on an uploaded file to match the source in an attempt to preserve file attributes.

Are you looking for a way to suppress a client's attempts to change file permissions?

--Jake

Mario Izaguirre 03-16-2017 03:56 AM

Hi Jake.

I send the response via email to support.

Thanks.


All times are GMT -6. The time now is 01:29 PM.