VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Scripting (https://forums.vandyke.com/forumdisplay.php?f=14)
-   -   multiscript to automate configuring cisco devices (https://forums.vandyke.com/showthread.php?t=11094)

serbant 06-25-2013 10:57 AM

multiscript to automate configuring cisco devices
 
Hi all, I have been running a multiscript that allows me to log into multiple routers (connections listed in a text file parsed at the beginning of the script) and send multiple commands to each router (another text file), one at a time.
This was used mostly to get output of various "show" commands, or to automate troubleshooting (run various pings or trace routes from multiple routers). All those commands are entered in the router's "enable" mode, but once I try to use the same script to actually configure multiple routers, the script stops when it gets into the "config" mode of the first router (with the "config t" command). The only way I could manage this is if I modify the sessions and add the "config t" command as part of the automated login, then I can use the multiscript to enter multiple configuration commands to multiple routers (as long as all those sessions have the "config t" as part of the router's automated login!). In short, the same script won't run commands in the "enable" mode (such as config t) AND in "config" mode at the same time!
Any ideas why and what would the fix be?
Thanks much!

bgagnon 06-25-2013 11:12 AM

Hello serbant,

What version of SecureCRT are you using?

On what platform?

Please post (or send to support@vandyke.com) the current version of the script you are trying to use.

If you attach the script to email, please include "Attn Brenda - Forum Thread #11094" in the subject line.


All times are GMT -6. The time now is 09:34 PM.