VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Open new sessions on the same instance (https://forums.vandyke.com/showthread.php?t=13243)

Portugal 09-03-2018 10:56 AM

[SOLVED] Open new sessions on the same instance
 
Hello.

I've been using SecureCRT for a while, great product :)
Now that I'm using eve-ng to emulate some routers, every time I click on a router it opens a new session on a new SecureCRT instance, instead of opening that session in a new tab on the same instance.
That's a problem, because if I've 20 routers on the topology, I'll have 20 instances of SecureCRT opened.

Is there a way to force SecureCRT to open new sessions on an already running instance.

I'm using SecureCRT 7.3.7 (x64 build 1034) on Windows 10 1803

Best regards.

berdmann 09-03-2018 11:40 AM

Hi Portugal,

If you navigate to Options > Global Options > Terminal, do you have the "Connect sessions in tabs" option enabled?

If not, please enable "Connect sessions in tabs".

Does enabling this option provide you with the desired behavior?

Portugal 09-03-2018 02:59 PM

Quote:

Originally Posted by berdmann (Post 50155)
Hi Portugal,

If you navigate to Options > Global Options > Terminal, do you have the "Connect sessions in tabs" option enabled?

If not, please enable "Connect sessions in tabs".

Does enabling this option provide you with the desired behavior?

Hello berdmann.
Yes, that option is already enabled.
It's strange that this behavior is exclusive of eve-ng. It doesn't happen with GNS 3.
Do you have any other suggestions?

Best regards.

Portugal 09-04-2018 06:01 AM

No other suggestions? :(
I've made a small video showing the issue --> https://mega.nz/#!qTAjzKgC!Rl6lyXMMK...HQ1B4KWA9xZ_aY
Does SecureCRT version 8 solve this issue? If so, I'll upgrade.

Best regards.

Portugal 09-04-2018 06:21 AM

Solved
 
Hello.

I've found a solution on comment made on a Youtube video.
In order to force SecureCRT to open a new tab instead of a new session, open the Global.ini file located on \Users\<username>\AppData\Roaming\VanDyke\Config, locate the line:
D: "Single Instance" = 00000000
and change it to:
D: "Single Instance" = 00000001

berdmann 09-04-2018 10:44 AM

Hi Portugal,

I am happy to hear that you were able to find a work-around by forcing SecureCRT to use a single instance!

Have a great day!

Manjinder 09-27-2019 02:19 PM

Solution Worked for me as well.

Thank you for the solution !!.

In order to force SecureCRT to open a new tab instead of a new session, open the Global.ini file located on \Users\<username>\AppData\Roaming\VanDyke\Config, locate the line:
D: "Single Instance" = 00000000
and change it to:
D: "Single Instance" = 00000001

MRAQAMKL 11-03-2019 05:18 AM

Tab in EVE-NG
 
Changing - D: "Single Instance" = 00000001
did not work for me.. not sure why EVE opens an instance of Secure CRT for each session. I do hope there is a better solution..

berdmann 11-04-2019 11:02 AM

Hi MRAQAMKL,

I am not familiar with EVE. Do you mind elaborating on EVE and how you are launching your SecureCRT sessions?


All times are GMT -6. The time now is 05:56 PM.