VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Secure Shell (https://forums.vandyke.com/forumdisplay.php?f=15)
-   -   Spurious migration dialogs (https://forums.vandyke.com/showthread.php?t=1693)

eddycurrents 09-11-2006 08:15 AM

Spurious migration dialogs
 
Hi, I have been having this problem on and off for a long time. I am using SecureCRT 5.1.2 but I think I have seen it in 5.0 or 5.1.

Sometimes when I start SecureCRT it triggers the migration dialog. It happens every few months. I have tried various things to stop it but nothing works, I have to just sit it out.

This is annoying. I have to wait for my sessions to copy to the new folder (I have > 1000 sessions, it takes several minutes), and then I have to set all my global options again.

Today it happened, and after migration I got the migration dialog again, three times in a row. I thought I was screwed! I fiddled with the VDSRedirect file and the registry settings and did a bunch of migrations and after about 30 minutes I made it go away. I don't remember all that I did.

Please help! What triggers the migration dialog?? How can I stop it from coming up? I lost a half hour of productivity when I could least afford it.

I saw an old post about someone who got the little migration notice (not the big dialog, like I'm getting). I tried your advice there, of adding the /F option to the shortcut, but it didn't help.

I did get the little migration notice at one point in my fiddling. Adding the /F option didn't get rid of it. I eventually did get rid of this notice but I don't know how, exactly.

tnygren 09-11-2006 01:02 PM

Hi Eddycurrents,

It is hard to tell what may have happened to cause these migrations to occur.

I need to get some more information to see what happened.

The migration wizard does log what happens during the migration attempts. This log is located in the current configuration folder that SecureCRT is using and is called migratelog.txt.

Could you send me this log file?

This information can also be obtained in the final screen of the migration wizard. Just wait for it to complete and copy all the text from that dialog.

Is '/F' still being used on the command line?

Are there any other versions of SecureCRT installed on this system?

Do any folders named 'Config' exist in SecureCRT's installation folder?

Would it be possible to have you send me a zip file of your configuration?

Also, could you export the following registry key and send that to me also?

HKCU\Software\VanDyke

Since these can contain information that should not be posted on a public forum, feel free to email this to me at support@vandyke.com with a subject of ATTN: Teresa Forum Thread 1693.

Justin Butterwo 01-12-2007 05:30 AM

Same problem
 
Hi We have the exact same issue - I'm attempting to write a quick script to silent install/upgrade our desktops from Scrt 4.1 -> 5.2 Unfortunatly I am repeatedly prompted to migrate once the upgrade occurs(if I see another config folder with VanDyke appended to the end I'll scream:p ) The migration occurs the new folder migration log has no errors and everything appears tickety boo.
It doesn't seem to matter what I do I can't get a stable none migration setup. The closest I've come is to run the upgrade and then put a VDSRedirect.ini in the new folder pointing back to itself. This comes up with a prompt warning to use a different folder (listed as the same one) but loads the sessions fine.

Is the a file flag or registry setting which I could set to get me out fo this migration nightmare - we have around 500 sessions an dI don't want to have to create them a new under version 5 just to stop this loop.

Cheers,

Justin Butterworth

tnygren 01-12-2007 07:46 AM

Hi Justin,

I'm sorry to hear that there are migration issues.

I just had a couple of questions.

Where is the original configuration ('Config') folder residing on the system?

Would it be possible to get a copy of the migration log to see what is happening during the migration?

Since the log can be rather large with 500 sessions, could you send me the log directly?


All times are GMT -6. The time now is 01:22 AM.