VanDyke Software Forums

VanDyke Software Forums (
-   File Transfer (
-   -   SecureFX - Not showing links as expected (

Trey 03-18-2020 04:29 PM

SecureFX - Not showing links as expected
2 Attachment(s)
I connect to a lot of ESXi machines. One of the user writable sections of ESXi is directory called Scratch, which is a link to one of the VMFS datastores.

SecureFX sees this as just a file. This is a problem as it doesn't allow easy navigation to where I need to go.

I had been using WinSCP, which doesn't have a problem with this.

I have attached screenshots from both to show what I am describing.

I also looked through the various options/preferences in SecureFX and couldn't find anything for this. Maybe I missed it?


berdmann 03-18-2020 05:42 PM

Hi Trey,

Thanks for providing the screenshots! What version of SecureFX are you running?

What protocol are you using to connect?

What behavior do you experience if you double-click on "scratch" in SecureFX?

Trey 03-18-2020 11:35 PM


I'm using version on Windows 10:
Version 8.7.1 (x64 build 2171) - Official Release - March 17, 2020

I'm connecting I think through SFTP. I connected first to the IP over SSH with SecureCRT. And then I clicked on the launch SecureFX button.

If I double click on scratch, it thinks it's a file I want to download, and throws in the console with the below message:


i Transfer(0x00013C6800000005): Skipping transfer: unresolved link '/scratch'.
i Transfer(0x00013C6800000005): Attempted to transfer 0 files.
i Transfer(0x00013C6800000005): Transferred 0 files successfully.


berdmann 03-19-2020 10:28 AM

1 Attachment(s)

If you navigate to Options > Global Options > File Transfer > Options, is the "Resolve symbolic links" option disabled?
If so, what is the behavior that you experience after enabling this option?

If SecureFX is still treating the link as a file, please send me a trace log that captures your attempt to use the link. You can enable logging in Global Options > File Transfer > Options > Advanced.

Please send the log as an attachment to an email to with "ATTN: Brittney, Forum Thread# 14110"in the subject line.

Trey 03-19-2020 01:28 PM

1 Attachment(s)

Setting that in the Global Settings did the trick.

It's weird, with that unset in Global, but checked in the actual session, it was not resolving them. I then noticed in the session, you can have a check, a black box, and then empty.

What's the difference between a check and the black box?


berdmann 03-19-2020 04:18 PM

Hi Trey,

I am glad to hear that enabling the "Resolve symbolic links" setting in Global Options did the trick! The session setting is a tri-state setting. Meaning that SecureCRT will honor the global setting if the square is filled in in Session Options.

If you have the box checked in Session Options, the "Resolve symbolic links" setting will be enabled for the session regardless of the global setting.

Does this information help to clear up the difference between the two?

All times are GMT -6. The time now is 12:02 PM.