VanDyke Software Forums

VanDyke Software Forums (
-   SecureCRT on the Mac (
-   -   8.5 Beta1/Beta2 multi-line paste issue (

2mmy 07-12-2018 07:59 AM

8.5 Beta1/Beta2 multi-line paste issue

I have now tried both Beta1 and Beta2, and the multi-line paste behaviour seems to have changed from release 8.3.x
Now the focus is in the text window, and "enter" will of cause not paste.
I use the window just to verify that I have the right content in the clipboard, and if so I just want to paste the content. So for my workflow, focus should be on the "paste" button.

Not sure if this is a bug, or an intended change in behaviour?

Best regards
Tommy Vindvik

ekoranyi 07-12-2018 09:28 AM

Hi 2mmy,

I'm having some trouble reproducing the behavior your describing. What Operating System are you running SecureCRT on?

So far I've tested on Windows using SecureCRT 8.5.0 (x64 build 1696). The steps I've used are:
  1. Copy multiple lines of text
  2. Right click in the session window and choose paste

This opens the Confirm Multi-line Paste window with the Paste button having focus, I can simply press enter to send the information.

Is there a set of steps I could take to recreate this behavior?

2mmy 07-13-2018 04:20 AM


My post is in the "SecureCRT on the Mac" forum :)
Running Mojave 10.14 beta 2 (18A326h).

Tommy Vindvik

ekoranyi 07-13-2018 09:37 AM


I'm sorry I missed that this was the Mac forum, thanks for the additional information.

Testing on the Mac I was able to reproduce the behavior change you described. I've asked our QA/DEV team to review the issue and will be sure to let you know as soon as I have additional information.

If you would like to contacted directly please send an email to with "Forum Post 13171" in the subject.

ekoranyi 07-13-2018 09:57 AM


While our QA/DEV team continues to investigate the issue we may have a workaround that will help provide the behavior you're looking for. Making a change to the Mac's settings seems to clear up the issue.

Please navigate to:


System Preferences->Keyboard->Shortcuts
In the Full Keyboard Access section select the All Controls radio button.

You can also use the key combination of Control-F7 to toggle this option. This would allow you to make this change on the fly, from within SecureCRT, without having to navigate the System Preferences menu.

Does this help get you the behavior you're expecting?

2mmy 07-16-2018 03:49 AM


That solved this issue. Thanks a bunch :)

Best regards
Tommy Vindvik

ekoranyi 07-17-2018 10:58 AM

Hi 2mmy,

I'm glad to hear the workaround is working as expected.

I also have further good news. Our QA/DEV team believes they have been able to correct the behavior you're seeing in a pre-release version of SecureCRT. I would like to make this version available for you to download and evaluate. If you would like to test this version please send an email to with "Attn Eric Forum Post 13171" in the subject line.

All times are GMT -6. The time now is 04:31 PM.