VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Secure Shell (https://forums.vandyke.com/forumdisplay.php?f=15)
-   -   Multiple passphrase prompts when connecting to multiple servers (https://forums.vandyke.com/showthread.php?t=12801)

renep 09-03-2017 04:09 AM

Multiple passphrase prompts when connecting to multiple servers
 
The activator is not running. When I start SecureCRT and select a folder with multiple servers in the connect dialog, and right click "Connect in tabs", SecureCRT opens and presents the "Enter Secure Shell Passphrase" dialog to decrypt my private key. I enter my passphrase and The first seccion is connected. So far so good.

But SecureCRT then immediately prompts me again for my Passphrase, apparently for the second session to another server. This is repeated for every session in the folder.

I'm not sure if this qualifies as a bug, but I find this behaviour annoying. I'd expect all sessions to connect when the passphrase is entered successfully only once.

I'm using SecureCRT 8.1.4 (build 1443) on Windows 10.

jjh 09-04-2017 10:44 AM

Hi René.

If you open your Global Options to the SSH2 category, you should see the "Add keys to agent" setting.

Is that setting enabled?

Thanks.

JJH

renep 09-04-2017 12:15 PM

Yes, it is.

jjh 09-05-2017 05:00 PM

Hi René.

The problem is likely that because you have selected many sessions to connect in tabs, they are all connecting immediately, before the key has been added to the agent following the first entry. It might help to have SecureCRT connect to each or the sessions sequentially instead of simultaneously. If you open your Global Options to the Terminal \ Advanced category, you can enable the "Connect multiple sessions sequentially" option. That should allow the key from the first connection to get added to the agent before the subsequent sessions try to connect.

Does that work for you?

Thanks.

JJH

renep 09-06-2017 07:43 AM

Yes, that solved the problem. Thank you.

Just curious, what is the advantage of simultaneous connections anyway? Shouldn't this option be set or assumed in this use case?

jjh 09-06-2017 10:46 AM

Hi René.

Personally, I have not encountered a situation in which I would have to actually have my session launch at the exact same time, but that doesn't mean that someone somewhere wouldn't say that they needed that functionality. It would be my guess that most users would be happy enough for their sessions to be launched sequentially.

A feature request exists in our feature request database for that setting to be enabled by default. I have added your comments from this forum thread to that request, so should a version of SecureCRT become available with that setting enabled by default, we will post something here. If you would like to be informed via e-mail, please send a message to support@vandyke.com referencing this forum thread and we will add it to your entry.

Thanks

JJH


All times are GMT -6. The time now is 01:35 AM.