VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT 5.1/SecureFX 3.1/VShell 2.6 Beta (https://forums.vandyke.com/forumdisplay.php?f=19)
-   -   B1/B2: Selection Problems. (https://forums.vandyke.com/showthread.php?t=593)

jad 03-18-2005 12:06 PM

B1/B2: Selection Problems.
 
Both betas have exhibited the following behaviour regarding selecting text...

When selecting text, I highlight the text, and when I let go it automatically copies it (Copy on Select is checked). Then, when the screen refreshes, when it would normally wipe out the selection, the selection remains, and any text on the new screen that is within the prior selection range is again highlighted as if I selected it.

It does not re-copy it...I still have the original copy buffer contents, but it is still highlighted until I do a no-characters-selected selection, at which point it goes away.


Cheers,
Jason

JDA 03-18-2005 02:26 PM

Re: B1/B2: Selection Problems
 
I am having the same problem. I'm using B1. The problem occurs even if there is only one tabbed CRT session active. The only time I've noticed it, so far, is when I'm using my editor, MicroEMACS. As you said, it appears to have a lingering "phantom highlighted region". I hope they can find a solution, because it's very distracting. This problem does not exist in SecureCRT 4.x.

Vlad Ershov 03-20-2005 02:32 AM

Just FYI:
The same problem has been described in this thread and still presents on both betas.

Maureen 03-22-2005 04:14 PM

We believe we have fixed this problem. If you'd like to try an interim build, please send your e-mail address to me at Maureen.Jett@vandyke.com.

Maureen

jad 03-24-2005 06:25 AM

I've tested the interim build (Build 808), and I am still experiencing the selection issues...

I'm seeing this on only one connection at this point, however. On my private co-located server, running Linux, I maintain an active screen session at all times. I regularly login and logout of my server, detaching and re-attaching to the screen session as needed.

When using Mutt, if I select a portion of text, and then issue other commands (say I select text from an email, then go back to the index of mails, open another mail, et cetera) I still experience the selection problem. Even if I issue a screen refresh (ctrl-l) it will not fix it.

It does not go away until I issue a command for screen that issues a redraw of the terminal, such as switching to another window or issuing a screen-based refresh (ctrl-a, ctrl-l).

So this now looks to be an issue with screen and SCRT...which is a huge impact to me as I use screen personally and professionaly. Is there any other information I can provide?


Cheers,
Jason

JDA 03-24-2005 08:15 AM

I have also tested Build 808, and am also continuing to have the selection problem. I've noticed that if I have two tabbed sessions open, that the problem occurs in both sessions, but independently of the other tabbed session. That is, if I select some text near the top of the screen in session 1, and then switch screens WITHIN that session (again, I experience this mostly using MicroEMACS), the highlighted region persists at that location on the screen. Then if I open session 2 to another host and do the same thing there, but select text near the bottom of the screen, the same phenomenon occurs in that session near the bottom. But if I flip between host sessions, the persistent highlighting stays put for the given session. The highlighting location does not cross over between host sessions. My two sessions were to different host types: one Linux and the other AIX, so apparently this is not OS-dependent.

I agree with "jad" that this is a significant problem, and one that would make me avoid the continued use of SecureCRT 5 until it can be fixed. And like "jad" I'd be happy to provide you with troubleshooting information. How about a "Raw Log Session" output file?

Thanks,
Jim

JDA 03-24-2005 09:01 AM

After offering to send you a "Raw Log Session" output file, I took a look at a few of them myself, and learned something about how MicroEMACS writes to the screen. If I am editing two files at once, and the two files are very similar, then when I ask MicroEMACS to switch from one file to the other, it only outputs to the screen the data that is DIFFERENT between the two screens (i.e. files), using the usual VT-100 escape sequences to position the writing of the screen data. Actually, I'm ASSUMING that it's MicroEMACS that exhibits this behavior -- but maybe it is some other software layer that comes between MicroEMACS and my SecureCRT program (like the tty driver in Linux?).

At any rate, I can see now why SecureCRT might not clear the "phantom" highlighting in this case. But on the other hand, SecureCRT 4 does handle this situation properly.

Hope this helps,
Jim

Maureen 03-24-2005 03:51 PM

Thanks for reporting this and for providing so much information. We'll look into it. The raw log could be helpful. Please send it to me at Maureen.Jett@vandyke.com.

Thanks,
Maureen

Maureen 03-30-2005 09:21 AM

A fix for this problem was just made and will be available in beta 3. If you'd like an interim build in the meantime, please send me an e-mail at Maureen.Jett@vandyke.com.

Maureen


All times are GMT -6. The time now is 10:19 AM.