VanDyke Software Forums

VanDyke Software Forums (
-   General (
-   -   cant port forward (

mrjoli021 08-30-2021 09:36 AM

cant port forward
I running securecrt on a Mac, and I am trying to port forward in the following manner.
RemoteForward 52698 localhost:52698

I have unde default session options - > Port Forwarding:
Manual select local IP box is unchecked
Port: 52698

Destination host is different from ssh server unchecked
Port: 52698


Error message I am getting:
/usr/local/bin/rmate: connect: Connection refused
/usr/local/bin/rmate: line 412: /dev/tcp/localhost/52698: Connection refused
Unable to connect to TextMate on localhost:52698

When I use the terminal to ssh into the box it works, but not with securecrt. What am I missing?

kdmorse 08-30-2021 08:45 PM

I'm 95% sure that for your use case of Remote Port Forwarding (not Local Port Forwarding), you need your ports specified on the Remote/X11 tab (right below the "Port Forwarding" tab).

mrjoli021 09-01-2021 07:44 AM

I have changed it on the remote side, restarted the connection. Now I am not getting any error messages, but I am not getting sublime to open up. When I ssh into the same box through the terminal and run the exact command sublime opens up. What am I missing?

gregg 09-01-2021 08:26 AM

Before connecting to the remote host, you can turn on File -> Trace Options to see some additional messages related to ssh.

And then also try your failing command with trace options on.

It sometimes provides hints.

All times are GMT -6. The time now is 07:56 AM.