VanDyke Software Forums

VanDyke Software Forums (
-   General (
-   -   Help Getting ANSI Working Correctly (

F4RR4R 03-24-2012 04:02 PM

Help Getting ANSI Working Correctly
I'm trying to get ANSI support working correctly with the following scenario.
I've got an Ubuntu 11.10 server running where I do most of my work. I do a lot of work in VIM.

VIM colorschemes typically make use of 256 colors. They're listed here:

So, I've built a profile in SecureCRT that connects to my server using XTerm as the terminal type with ANSI enabled. The default VIM colorscheme only uses 16 colors and they display correctly. However, as soon as I attempt to use a colorscheme that branches out past those basic 16 colors, I don't see them anymore.

I see in SecureCRT itself in the ANSI tab that there are only 16 colors I can configure in the GUI.

I tried setting my term-type to xterm-color and xterm-256color with no luck, same problems.

Will SecureCRT not support more than 16 colors? I really hope that's not the case, I really like SecureCRT, but I'd like 256 color support.

If it was possible to create a file that specified the RBG codes to be used for specific colors (rather than doing this through the GUI) that would be much better as well. :)

MrC 03-25-2012 01:18 AM

1 Attachment(s)
SecureCRT supports 256 colors. See screenshot.

Try the vim colortest located here;

Its a perl program you can run to see the colors output.

You do need ANSI Color enabled.

F4RR4R 03-25-2012 04:30 PM

Yeah, the colors display beautifully. Must be something broken in my VIM configuration. Thank you :)

F4RR4R 03-25-2012 04:37 PM

Just in case anyone else stumbles upon this ...
My server is Ubuntu 11.10x64 & I'm using VIM 7.3. When I am connected locally using gnome-terminal I have 256 color support in VIM. When I connect remotely, I only have 16 color support. The terminal type is XTerm.

I found the solution to my problem on the following link:

Adding the following line into my .vimrc added support for 256 colors over a remote XTerm session: set t_Co=256

All times are GMT -6. The time now is 08:07 AM.